[Buildroot] Compiling and loading modules

Michel Benoit murpme at gmail.com
Sun Dec 17 19:44:32 UTC 2006


Hello,

I am using buildroot to build and run a Linux 2.6.19 kernel and root
file system.
The kernel compiles and runs ok and (at this stage) I am using the
root.arm.ext2 file as an initrd root fs in ram. My target is an arm
atmel cpu (AT91SAM9260).

I am trying to build and load a simple hello world kernel module.
I build the module from the same tree as the linux kernel but when I
run ismod I get the message "Illegal Instruction".  I get the same
response when I try to insmod other kernel modules built automatically
in the tree.

What can be the cause of the "Illegal instruction"?
Does this indicate that I am not cross compiling correctly?
Is the ko object corrupt or in the wrong format (endianess perhaps)?

I am using modutils from busybox. Are there any busybox options that need to be
added/removed? I have tried enabling module config options in busybox
and the kernel but I always get the same error.

It feels like this is a build issue but I can't see why the kernel
builds ok but the modules don't.

Thanks,

Michel



More information about the buildroot mailing list