[Buildroot] Building x86_64 failes

Goetz Bock bock at blacknet.de
Fri Jan 19 13:31:53 UTC 2007

Dear list,

after I've successfully build buildroot for i586 on my
amd64/debian/sarge box, I wanted to build the same rootfs for amd64.

So I copied the existing buildroot, removed build_i586 and
toolchain_build_i586, ran make clean and make menuconfig to
reconfigureit for x86_64.

But building the toolchain failes with:

In function 'x86_fallback_frame_state':
error: 'struct sigcontext' has no member named 'esp'
. [ more missing e?? members ]

It does not matter what version of binutils/gcc I use, it's always the
same error.
(I've tried binutuils: 2.16.1, 2.17,, and gcc
4.0.3, 4.1.1, 4.2)

The i386 realy irritates me, and I've no idea where it comes from.

Any pionters?
/"\ Goetz Bock at blacknet dot de  --  secure mobile Linux everNETting
\ /       (c) 2006 Creative Commons, Attribution-ShareAlike 2.0 de
 X   [ 1. Use descriptive subjects - 2. Edit a reply for brevity -  ]
/ \  [ 3. Reply to the list - 4. Read the archive *before* you post ]

More information about the buildroot mailing list