[Buildroot] Odd behavior when displaying locale date and decimal information

Zachary P. Landau kapheine at gmail.com
Fri Mar 9 15:37:50 UTC 2007

I have a little more information on this problem.  I ran the
localeconv() call on the target and looked at some of the data
returned.  conv->decimal_point returns an empty string, rather than
"." as I would expect.  That would probably explain why the decimal
numbers are missing from printf.

setlocale() says the current locale is set to "C" which is what I
would expect.  But for some reason it seems the correct locale
information is missing from it.  I tried looking through uClibc's
locale code to see if there were any ifdefs that maybe I messed up
while configuring buildroot, but I couldn't find any that seemed to
help.  But there is a lot of code there, maybe someone else has a
better idea.

By the way, I am posting to the buildroot mailing list because I'm
guessing that it is a configuration issue and not an actual bug with
uClibc.  But if others disagree then I can post on the uClibc mailing
list instead.

Zachary P. Landau <kapheine at gmail.com>

More information about the buildroot mailing list