[Buildroot] Segmentation fault of running sudo

Weichen Lee (李威震 - Askey - TW) weichen.lee at askey.com.tw
Thu Sep 20 10:10:46 UTC 2007


I downgrade uClibc to
It solved this problem.


-----Original Message-----
From: Yehuda Hahn [mailto:Yehuda.Hahn at sandisk.com]
Sent: Thursday, September 20, 2007 5:51 PM
To: Weichen Lee (李威震 - Askey - TW)
Subject: RE: [Buildroot] Segmentation fault of running sudo


I had a similar problem with a number of packages, and solved it by downgrading uClibc to



-----Original Message-----
From: buildroot-bounces at uclibc.org [mailto:buildroot-bounces at uclibc.org] On Behalf Of Weichen Lee (??? - Askey - TW)
Sent: Thursday, September 20, 2007 11:07 AM
To: buildroot at uclibc.org
Subject: [Buildroot] Segmentation fault of running sudo

I use buildroot (svn r19828) to make the toolchain with the version below

kernel-headers 2.6.11
binutils 2.17
gcc 4.1.2
uClibc 0.9.29

There is no error during compiled time.
The sudo package is also compiled successfully.
The rootfs with program like busybox is work fine on the target board.
But when I run sudo, the output message is only show "Segmentation fault".
 Does anybodyelse encounter the same issue?

Best Regards

研三本部 高級工程師

李威震 (Weichen Lee)

TEL:03-4759460  EXT:872
E-mail:weichen.lee at askey.com.tw

More information about the buildroot mailing list