[Buildroot] Error during make

Daniel Endres d.endres at meteocontrol.de
Mon Aug 18 17:02:40 UTC 2008

Hello Bernhard,

first of all, thanks for your quick reply.
Ok, missing libm functionaliy seems to be the problem. But how do I 
configure my libc-library? You did mean "configure your uclibc" didn't you?

I've tried to configure my uclibc as stated in the docs/Readme via "make 
uclibc-menuconfig", but there isn't any possibility to configure libm 

Am I digging in  the wrong spot ?

Thanks for your help

Greetings, Daniel
> On Wed, Aug 13, 2008 at 04:45:15PM +0200, Daniel Endres wrote:
>> Hello Guys,
>> I'm trying to build a toolchain as well as rootfs for a mipsel device.
>> Therefore I'd like to use buildroot. The problem is that I'm getting
>> some undefined references errors during the awk-build. Obviously the
>> errors are due to a missing math-library.
>> I've just downloaded the latest snapshot in the first place and tried
>> the svn-version later on.
>> Both giving me the same errors.
>> I've just done a "make menuconfig" for buildroot, changed the target to
>> mipsel, exited and hit "make".
>> I don't know if I'm wrong, but shouldn't a clean build succeed ?
>> Below I've posted my error-log. Hopefully some could point me in the
>> right direction.
> Well, as you correctly state you need stuff from libm, so configure your
> libc to provide the required libm functionality.
> see docs/README

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.busybox.net/pipermail/buildroot/attachments/20080818/387f4810/attachment-0001.html>

More information about the buildroot mailing list