[Buildroot] Kernel CONFIG_ROOT_NFS is ignored?

Fredy Yanardi fyanardi at gmail.com
Thu Jan 17 03:44:36 UTC 2008

Hello all,

I know this sounds rather stupid, but I've spent few hours figuring
out this thing. I'm using Buildroot to get a kernel + root filesytem
for at91rm9261-ek board. So far I've successfully build everything
(getting kernel image and root filesystem image)

The only problem that I can't boot from NFS using this kernel (no root
nfs support in kernel). I've tried to modify CONFIG_ROOT_NFS to 'y' in
but somehow seems that it is always been ignored when buildroot
applying the configuration. When I try to re-run make in buildroot
directory, it turns out that ROOT_NFS is always set back to 'n'. (I've
tried to modify other config options from the config file, and the
change is not ignored).

I'm using buildroot snapshot 16 January 2008. I've also set
CONFIG_IP_PNP to 'y', maybe I missed something else?

Thanks for all your help,


More information about the buildroot mailing list