[Buildroot] buildroot openssl compile error

Brad Johnson bradjohn263 at comcast.net
Tue Apr 14 03:10:39 UTC 2009

Hello Thomas,
I tried to build the latest (4/13/09) svn version of buildroot with my 
external buildroot toolchain (cross-compiler for arm). I assume the fix 
described in r25879 is in this version?
I still get an error compiling openssl:

/opt/arm-linux/usr/bin/arm-linux-gcc -I.. -I../.. -I../../include -fPIC 
CN_H -DTERMIO -O3 -fomit-frame-pointer -Wall   -c -o c_zlib.o c_zlib.c
c_zlib.c:25:18: error: zlib.h: No such file or directory

I do not see a --sysroot gcc argument. There is a 
Please advise me as to how I can build openssl within buildroot using an 
external toolchain.


On 4/13/2009 3:08 PM, Thomas Petazzoni wrote:
> Le Mon, 13 Apr 2009 20:03:50 +0200,
> Peter Korsgaard <jacmet at uclibc.org> a écrit :
>> There's no -I$(STAGING_DIR)/usr/include in the gcc invocation, so that
>> probably fails with an external toolchain.
> There's no need for -I$(STAGING_DIR)/usr/include with an external
> toolchain if --sysroot $(STAGING_DIR) is passed (at least my
> experiments confirm this). See r25879.
> Thomas
> ------------------------------------------------------------------------
> No virus found in this incoming message.
> Checked by AVG - www.avg.com 
> Version: 8.0.238 / Virus Database: 270.11.54/2056 - Release Date: 04/13/09 05:51:00

More information about the buildroot mailing list