[Buildroot] [Bug 331] Update MPlayer to version 1.0rc2

Ulf Samuelsson ulf.samuelsson at atmel.com
Thu Aug 6 23:54:18 UTC 2009

Ulf Samuelsson skrev:
> bugzilla at busybox.net skrev:
>> https://bugs.busybox.net/show_bug.cgi?id=331
>> Peter Korsgaard <jacmet at uclibc.org> changed:
>>            What    |Removed                     |Added
>> ----------------------------------------------------------------------------
>>              Status|ASSIGNED                    |RESOLVED
>>          Resolution|                            |FIXED
>> --- Comment #7 from Peter Korsgaard <jacmet at uclibc.org>  2009-07-27 15:17:32 UTC ---
>> Thanks, committed!
> Are there anyone except HCE which has mplayer running properly?
> I tried mplayer-1.0-rc1 with a SAM9263 kernel downloaded from
> www.linux4sam.org.
> I have tried with root file systems generated by OpenEmbedded and Buildroot.
> It works with OE, but not with BR.
> I also tried with the new 2009.08-rc2 which upgrades mplayer
> and the same problem occurs. Only tested with a BR system.
> I should have a a valid /etc/asound.conf and /etc/asound.state.
> Some symptoms:
> The status line looks like:
> A: (15) (01.4) of 1700 (02:50.0) 21056% $<50>
> THe first number indicates which chunk is beeing processed,
> and this counts up VERY slowly with the BR root file system,
> and much MUCH faster with the OE root fs.
> The 21056% figure seems strange...

If I understand this figure correctly, then this
means that the CPU needs to be 21x faster to
handle MP3 real time.
It increases the chunk counter by a few every 10 seconds
or so, while the OE mplayer increases the chunk counter
a few times per second.

I now can get sound when I play a simple wav file.

Could this mean that OE uses a fixed point MP3 decoder
while Buildroot mplayer uses a floating point decoder?

Ulf Samuelsson

More information about the buildroot mailing list