[Buildroot] bash fails to compile with git tree

Peter Korsgaard jacmet at uclibc.org
Mon Aug 31 08:15:47 UTC 2009

>>>>> "Daniele" == Daniele Salvatore Albano <d.albano at gmail.com> writes:


 Daniele> have someone tried to compile bash? Yesterday, trying to fix
 Daniele> my buildroot to send patches i moved my tree and cloned the
 Daniele> head to get a working one (i got some problems with git) but
 Daniele> when i tried to compile my root system, without applying any
 Daniele> patches i done (i was just waiting to get errors to apply
 Daniele> patches), bash failed to compile with a strange reason:
 Daniele> missing termcap.h

 Daniele> Checking ncurses and bash make files seems all ok, and making
 Daniele> a diff with my old tree showed no differences. Toolchain works
 Daniele> perfectly because i can build mi initrd (i use two separate br
 Daniele> trees) without any problem and that br2 is from git and is up
 Daniele> to date too. I don't build bash on my initrd, only busybox
 Daniele> with few stuff.

 Daniele> I can't send my .config, i'm at work, when i'll get at home
 Daniele> i'll send it, however someone got problems building bash?

Is this with an external toolchain? I just did a quick test build on
i686 with the normal internal toolchain and bash builds without problems

Bye, Peter Korsgaard

More information about the buildroot mailing list