[Buildroot] can't create /dev/ttys0 on cirrus ARM EP93XX

anthony henderson development at fair-games.com
Sat Aug 7 16:10:42 UTC 2010

Hi all,
I've built a new rootfs for a cirrus logic EP93XX chip, the rootfs provided
is very old and no extras cross compiled software (directfb etc).

So I've ran buildroot for the ARM 920T.  All seems fine.  As the board has
no keyboard ect development is done via serial port.  This is set in the old
rootfs from etc/initab via

I tried to start the new rootfs, but it appears to want to start from video
command prompt.  So I copied the inittab from the old working system to the
new rootfs, this gave an error finding ttyAM0.
On searching the new rootfs I can see dev doesn't have this node.  I can see
ttyS0, so I thought this might be used?  I tried changing the command to
ttyS0::askfirst:-/bin/sh.  But all this shows on screen is

/bin/'sh: can't create /dev/ttyS0: No such device or address.

While my pc serial port just keeps repeating

 /bin/'sh: can't create /dev/ttyS0: No such device or address.
/bin/'sh: can't create /dev/ttyS0: No such device or address.

Can anyone advise.  I new to embedded Linux so am finding information hard
to come by.  Thanks in advance :)

Regards Tony
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.busybox.net/pipermail/buildroot/attachments/20100807/09b7c6af/attachment-0002.html>

More information about the buildroot mailing list