[Buildroot] Nanosleep hangs

Zdeněk Materna zdenek.materna at gmail.com
Tue Mar 1 08:03:28 UTC 2011

Dne 28. února 2011 20:06 Zdeněk Materna <zdenek.materna at gmail.com> napsal(a):
> Hello,
> I would like to ask - is there any issue with nanosleep function?
> Clock_nanosleep is
> unimplemented in uClibc (right?) so I planed to use nanosleep instead
> of it. But it doesn't work for me - program hangs on it forever.
> Usleep works, but it's not good alternative, isn't it? I'm also going
> to utilize timers - are there any issues about them? However google
> didn't give me much useful answers. I tried it with uClibc 0.9.31 and
> 0.9.32-rc2 (snapshot version didn't compile).
> I'm sorry for cross posting - originally posted to uclibc mailing list
> but without any
> response. Thanks for any advice and sorry for poor English.
> My environment: uClibc 0.9.32-rc2, ARM (AT91SAM9260), kernel
> (with RT path and hi-res timers enabled).
> Best regards,
> Zdenek Materna


problem with nanosleep solved - it was between chair and keyboard. As usually...

Best regards
Zdenek Materna

More information about the buildroot mailing list