[Buildroot] [git commit master 1/1] Makefile.autotools.in: add libtool v2.4 support

Peter Korsgaard jacmet at uclibc.org
Mon Mar 28 22:23:57 UTC 2011


>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni at free-electrons.com> writes:

 Thomas> On Mon, 28 Mar 2011 21:45:06 +0200
 Thomas> Peter Korsgaard <jacmet at sunsite.dk> wrote:

 >> Packages (like avahi) are now using libtool 2.4, so extend the libtool
 >> handling to support those as well.

 Thomas> I thought libtool v2.4 was supposed to support --sysroot and therefore
 Thomas> to not need any of our dirty cross-compilation tricks. Am I wrong ?

Well, avahi failed for me atleast with dependent libs (it tried to
relink during installation against native libs) - With the patch it
works here, but I must admit I didn't look into the details.

-- 
Bye, Peter Korsgaard



More information about the buildroot mailing list